SUMMARY = "My Custom Hello Example Application"
|
|
# Linces file is in poky/meta/files/common-licenses/ and use `md5sum` command to get the MD5 value
|
LICENSE = "GPL-2.0-or-later"
|
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-or-later;md5=fed54355545ffd980b814dab4a3b312c"
|
|
# recipe version
|
PV = "1"
|
PR = "r0"
|
|
# There is /usr/bin/hello link to hello.lmbench, so can not use application name 'hello' here
|
SRC_URI = "file://hello-app.c \
|
file://Makefile \
|
"
|
|
S = "${WORKDIR}"
|
|
do_compile() {
|
make
|
}
|
|
do_install() {
|
install -d ${D}${bindir}
|
install -m 0755 hello-app ${D}${bindir}/
|
}
|