FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
|
SRC_URI:append = " file://uboot-imx-lf-6.1.36-2.1.0.patch "
|
|
do_deploy:append:igkboardbase() {
|
# Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
|
if [ -n "${UBOOT_CONFIG}" ]
|
then
|
for config in ${UBOOT_MACHINE}; do
|
i=$(expr $i + 1);
|
for type in ${UBOOT_CONFIG}; do
|
j=$(expr $j + 1);
|
if [ $j -eq $i ]
|
then
|
install -d ${DEPLOYDIR}/${BOOT_TOOLS}
|
install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
|
install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${type}
|
fi
|
done
|
unset j
|
done
|
unset i
|
fi
|
}
|