DESCRIPTION = "Realtek RTL8723DU USB Wi-Fi/BT driver"
|
|
LICENSE = "GPL-2.0-or-later"
|
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-or-later;md5=fed54355545ffd980b814dab4a3b312c"
|
|
# Git repository and branch
|
SRC_URI = "git://github.com/lwfinger/rtw88.git;branch=master;protocol=https"
|
SRCREV = "${AUTOREV}"
|
|
# Specify where the source files will be fetched to
|
S = "${WORKDIR}/git"
|
|
# Inherit the module class to handle kernel module compilation
|
inherit module
|
|
# Define the compile task
|
do_compile() {
|
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
|
oe_runmake all
|
}
|
|
# Define where to install the kernel module
|
do_install() {
|
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
|
install -m 0644 ${S}/*.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
|
}
|
|
# Add the driver to the kernel modules list
|
KERNEL_MODULE_PROBECONF = "rtw_8723du"
|