guowenxue
2024-07-18 a580f673d8120c96b9a854cd70ae2ebc8a048c57
yocto/meta-igkboard/images/yocto-image-full.bb
@@ -8,12 +8,10 @@
#IMAGE_ROOTFS_EXTRA_SPACE = "512000"
inherit extrausers
# Create the password hash with following command on host:
# >> mkpasswd -m sha256crypt password -S abcd6789
# Remember to escape the character $ in the resulting hash
# Set the root password:
#PASSWD="\$5\$abcd6789\$Vuv1aLz04ZwhxgsB3lOQbwy1XUS6PJ.8h2A7.9HoUd3"
# Set the root password:  >> mkpasswd -m sha256crypt 123456 -S abcd6789
# Remember to escape the character $ in the resulting hash
#PASSWD="\$5\$abcd6789\$2ayD.ZPdq5xejNiyE3XC3qCpkGZ.brSE5H0zSECVBSB"
EXTRA_USERS_PARAMS = "\
    usermod -p '${PASSWD}' root; \
"